Header Ads

Como converter hora em formato cecimal para o formato HH:MM:SS,MS.






Como alternativa é possível inserir 0:0:  , antes do valor decimal, mas a  estratégia torna-se cansativa conforme o andamento do trabalho. Para converter um valor hora expresso em formato decimal podemos utilizar a função TEXTO que é responsável por converter um número em texto de acordo com um formato especificado.
No exemplo abaxio queremos converter a número 261,096018 em  00:04:21,10

A1
B2
261,096018
00:04:21,10

Então podemos  inserir a  seguinte fórmula na célula B2 para obtermos o resultado almejado.

=TEXTO(B1/86400;"h:mm:ss,00")

Veja  o exemplo real passada por um de nossos integrantes no LibreOfficeBR um grupo de usuários da suite LibreOffice no Telegram.         
Onde  era necessário converter todos os rótulos de áudio exportados do Audacity no formato decimal para o formato   HH:MM:SS,MS.                                                                                                                                                  
Confira como ficou a saída





Nenhum comentário:

Tecnologia do Blogger.